Fix for Unified Attendant Console Standard V11.0.2.2571 – CSCva24885

As you may know with he release of CUCM 11.5 there were lots of issues with the Attendant Console applications, one of the related to a bug defect CSCva24885. September 16 there was a new update and instructions on how to install the attendant Console with CUCM 11.x

This post looks at 2 different levels of issues, the actual technical issue and discrepancies on Documentation for the solution. Also the post is looking to point out the solutions that are provided, in hopes that you can finally solve the issues you are currently having with your install

The Issue

The issue refers to the reported bug – CSCva24885, this issue will make the Splash screen of the Console to get stuck at initialization, and in some cases the Console will just work by following this procedure:

1) Install CUACS 11.0(2), following the instruction within the installation guide
2) Uninstall Cisco TSP v11.5 (Start > All Programs > Cisco TSPx64 > Uninstall Cisco TSPx64)
3) Install Cisco TSP v11.0.1. The installers are located within the Cisco TSP Installers folder. When prompted to restart, select Restart Later.
4) Carry out the following:
a) Click Start > All Programs > Cisco TSPx64 > Cisco TSPx64 Configuration
b) Click Configure
c) Under the General tab > Auto Update Information, select Never AutoUpdate
d) Click Ok, then Ok
e) Restart the PC

Cisco will package the TSP driver for an old version to install on the Computer and will instruct you to select Not to Auto-Update from the version in CUCM. This is because at the time of the installation the Console will get its TSP driver from the CUCM in real time.

I also found other issues and made it very complicated to really point out to the root of the issue, and in some cases just the actual computer where the application was installed did not help too much.

The Solution

When downloading at the Installer again from the Cisco webpage http://www.cisco.com/go/ac I noticed that there was a new fix, which by testing it further made it work with really no effort. There was no uninstalling of the TSP –> Restaring the Computer –> Re-Install TSP from old version –> Restarting the computer and pray that the issue was resolved.

Now the procedure looks at something like this:

Defect CSCva24885 requires users to apply the included patches after installing Cisco Unified Attendant Console Standard.

Cisco Unified Attendant Console Standard – Patch v11.0.2.471 – Installation Instructions

This patch should only be installed when using the console with Cisco Unified Communications Manager 11.5.x.

By applying this patch to an install, you may use the 11.5 tapi version installed during the installation of Cisco Unified Attendant Console Standard as opposed to carrying out the workaround referenced under CSCva24885- https://bst.cloudapps.cisco.com/bugsearch/bug/CSCva24885.

1) Close the “Cisco Unified Attendant Console Standard” Application
2) Navigate to \Program Files (x86 if using 64-bit OS)\Cisco\Cisco Unified Attendant Console Standard
3) Create backups of the x64 and x86 folders
4) Copy ASTAPI2x.dll from Patch – Dotnet_Win32 folder to the x86 repository from step 2.
5) Copy ASTAPI2x.dll from Patch – Dotnet_Win64 folder to the x64 repository from step 2.
6) Installation complete, you may resume operation of the console.

There was really not praying at this point and the Console worked perfect! – Note that this fix could only be applied to installations with CUCM 11.5

The Issue that I notice going forward

Now that we can definetly put this issue to rest, I wan to point out to something while writing this post I noticed. One of the main issues that I find with Cisco documentation is that is really hard to understand and decipher… and in some cases like this you will find that there are some teams that are not alligned properly. However this is I will say expected since there are different and huge departments working on providing solutions for clients.

If you notice the following link (Need to login with CCO):
https://bst.cloudapps.cisco.com/bugsearch/bug/CSCva24885/?referring_site=bugquickviewclick

The fix is still not updated on the Bug Tool according to the fix that you see in the installation folder coming from http://www.cisco.com/go/ac This one will require you to create a new account and have it authorized by the team that handles the Attendant Console website.

Last Words

In case you have questions and need some help clearing up a bit more on the root of the solution, feel free to reach out by commenting on this post.

About the Author:

Andres Sarmiento, CCIE # 53520 (Collaboration)
With more than 13 years of experience, Andres is specialized in the Unified Communications and Collaboration technologies. Consulted for several companies in South Florida, also Financial Institutions on behalf of Cisco Systems. Andres has been involved in high-profile implementations including Cisco technologies; such as Data Center, UC & Collaboration, Contact Center Express, Routing & Switching, Security and Hosted IPT Service provider infrastructures.

You can follow Andres using Twitter, LinkedIn or Facebook

Advertisements

One thought on “Fix for Unified Attendant Console Standard V11.0.2.2571 – CSCva24885

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s